Login x
User Name:
Password:
Social Links Facebook Twitter YouTube Steam RSS News Feeds
Watch MODSonair

Members Online

»
0 Active | 6 Guests
Online:

LATEST FORUM THREADS

»
Heroes 7 Part 3 and 4
CoD4 Map + Mod Releases
Error on map start
CoDWW SP Mapping

Forums

»

Welcome to the MODSonline.com forums. Looking for Frequently Asked Questions? Check out our FAQs section or search it out using the SEARCH link below. If you are new here, you may want to check out our rules and this great user's guide to the forums and the website.
For more mapping and modding information, see our Wiki: MODSonWiki.com

Jump To:
Forum: All Forums : Call of Duty 4
Category: CoD4 MP Mapping
CoD 4 mapping and level design for multiplayer.
Moderators: foyleman, Foxhound, Mystic, StrYdeR, batistablr, Welshy, supersword, playername, novemberdobby
Latest Posts
Subscribed Posts
Search
Restricted Access Restricted Access subscribe
Author Topic: Weapon index mismatch...
DeekCiti
General Member
Since: Mar 12, 2008
Posts: 1257
Last: Apr 18, 2014
[view latest posts]
Level 8
Category: CoD4 MP Mapping
Posted: Saturday, Jun. 14, 2008 11:32 pm
My map seems to be returning with the following error:

Weapon index mismatch for 'g36c_gl_mpgl_g36c_mp'

This error crashes the server.

Although this only started happening after I added Oldschool Mode, and only happens when I do a console /fast_restart or the map tries to switch to the next round, which is basically a fast restart. It does not matter what gametype is playing, it happens on all gametypes. All gametypes have been tested and run great.

The funny thing is, I don't even have this model anywhere in my map. Since it only started happening after I added Oldschool Mode, I'm guessing it has something to do with that. The only weapon pickups I have for Oldschool Mode are as follows:

Quote:

Loading model weapon_rpg7... successful.
Loading model weapon_winchest1200... successful.
Loading model weapon_usp_silencer... successful.
Loading model weapon_mini_uzi_silencer... successful.
Loading model weapon_m82... successful.
Loading model weapon_claymore_no_legs... successful.
Loading model weapon_m67_grenade... successful.
Loading model weapon_m40a3... successful.
Loading model weapon_remington700... successful.
Loading model weapon_us_smoke_grenade... successful.
Loading model weapon_concussion_grenade... successful.
Loading model weapon_c4... successful.
Loading model weapon_p90_sd... successful.
Loading model weapon_mp5sd... successful.
Loading model weapon_mp44... successful.
Loading model weapon_benelli_super_90... successful.
Loading model weapon_m60... successful.
Loading model weapon_m14_mp... successful.
Loading model weapon_m16gr_sp... successful.
Loading model weapon_dragunov... successful.
Loading model weapon_g3... successful.
Loading model weapon_g3_silencer... successful.
Loading model weapon_c4_mp... successful.
Loading model weapon_ak74u_supressed... successful.
Loading model weapon_ak47_grenadier... successful.
Loading model weapon_saw... successful.


This error consists of 2 models:

g36c_gl_mp
gl_g36c_mp


Here is a similar problem I found on some other forums
Quote:

GUY #1
At the end of a round of S&D as its starting the next round i get this error

Error: Index Mismatch for weapon "ak47_mp_silencerak47_mp_acog"

I'm loading in custom weapons for my bots.. however.. even with no bots spawned i still get this error.

Anyone seen this before???

----------------------
GUY #1

hmm, it seems to be caused by just precaching weapons files... i dont even use them just precache to get this to happen... perhaps there's some conflict in the stats system i'm unaware of....

----------------------
GUY #2

It looks like you're trying to use a weapon named "ak47_mp_silencerak47_mp_acog" which does not exist.
You've got 2 weapons here and you try to process it as a single weapon.

----------------------
GUY #1

I'm not doing anything with it in script.

If you make an empty mod that all it does is precache a weapon file, play s&d on showdown and wait for the round to end, you will get that error.


So thats the whole section I found on this problem. I also found something else like this having to do with the new 1.6 patch. I'm still using 1.5, so I know it has to be a mod conflict or something having to do with Oldschool Mode.

When I tested the map, I ran it on AWE4 from another machine and connected to it that way. Logged in as Admin and did /rcon fast_restart ... got the error. No error when I did /rcon map_restart. Then I tried it by simply running my MP game. Clicking on mods, tried AWE4, ModWarefare, and customMaps... all returned with the same error using /rcon fast_restart. Which leads me to believe that its not a mod problem, it must be a map or gametype conflict. I wouldn't care so much about it but if someone is playing the map, and their server uses a gametype that is round based and it tries to switch rounds, the server crashes...thats no good.

I guess my first troubleshoot will be to make a copy of my .map and in the copy I can remove all Oldschool entities, basically remove the gametype from my map and see if its Oldschool causing the static. I suppose if its not, I'll do the same for all gametypes till I find the problem, but if anyone knows whats the cause please let me know. I will even try adding one or both of those models to see if that fixes the problem.

Anyone know whats going on here? [sad]
Share |
DeekCiti
General Member
Since: Mar 12, 2008
Posts: 1257
Last: Apr 18, 2014
[view latest posts]
Level 8
Category: CoD4 MP Mapping
Posted: Sunday, Jun. 15, 2008 05:49 pm
O.K.

The problem seems to be resolved by adding the following models to Oldschool Mode:

weapon_g36c_gl_mp which = weapon_g36m203
weapon_g36c_acog_mp which = weapon_g36_mp


Entity Editor Info on Models:
----------
classname weapon_g36c_gl_mp
model weapon_g36m203

----------
classname weapon_g36c_acog_mp
model weapon_g36_mp
----------



The two files it gave me an error on as posted in post #1 were:

g36c_gl_mp
gl_g36c_mp



I don't know that I need them both, but by adding both in the same compile it fixed the error on fast_restart. It is possible that I only needed one model: weapon_g36c_gl_mp ...but I'm not going to test that since it is already working the way it is. I would assume that the model above is both of the models it wants in the error itself, which is why I'm coming to this conclusion. If I end up testing it, I will post again of my findings.

These are now the weapons I have loaded for Oldschool:

Quote:

Loading model weapon_g36_mp... successful.
Loading model weapon_g36m203... successful.
Loading model weapon_rpg7... successful.
Loading model weapon_winchest1200... successful.
Loading model weapon_usp_silencer... successful.
Loading model weapon_mini_uzi_silencer... successful.
Loading model weapon_saw... successful.
Loading model weapon_g3... successful.
Loading model weapon_m16gr_sp... successful.
Loading model weapon_dragunov... successful.
Loading model weapon_g3_silencer... successful.
Loading model weapon_c4_mp... successful.
Loading model weapon_ak74u_supressed... successful.
Loading model weapon_ak47_grenadier... successful.
Loading model weapon_m14_mp... successful.
Loading model weapon_claymore_no_legs... successful.
Loading model weapon_benelli_super_90... successful.
Loading model weapon_m60... successful.
Loading model weapon_mp5sd... successful.
Loading model weapon_c4... successful.
Loading model weapon_p90_sd... successful.
Loading model weapon_mp44... successful.
Loading model weapon_concussion_grenade... successful.
Loading model weapon_remington700... successful.
Loading model weapon_us_smoke_grenade... successful.
Loading model weapon_m40a3... successful.
Loading model weapon_m82... successful.
Loading model weapon_m67_grenade... successful.



I'm not quite sure why the game needs/wants these two models in for Oldschool. Are the default game loadouts for ModWarfare using these models? I'm still confused on why it wants these models in for Oldschool.
Share |
Restricted Access Restricted Access subscribe
MODSonline.com Forums : Call of Duty 4 : CoD4 MP Mapping

Latest Syndicated News

»
Codutility.com up and runn...
Great to see it,s back again http://www.codutility.com/
Valve, VAC, and trust: by ...
SOURCE: http://www.reddit.com/r/gaming/comments/1y70ej/valve_vac_and_trust/ ...
Codutility is for sale!
Seems like a plan to save Codutility ..Quote:Well guys I heard what you said...
Codutility is for sale!
Well as modding dies, so does the sites that support it.. Its a sad sad day,...

Partners & Friends

»